Ford-Rangers.com Ranger Forum HomeFord-Rangers.com Ranger Forum Home
Home Recent Topics New posts Search search Menu menu Not logged in - Login | Register

Ford-rangers.com is a discussion forum, a Ranger forum for people who have questions about fixing or modifying
their Ford Rangers or people who just admire their Ranger. Please join and enjoy sharing experiences!

What did you do to your Ranger today?       #: 49
 Moderated by: NoPower, Mike69, MaDMaXX, Page:  First Page Previous Page  ...  94  95  96  97  98  99  100  Next Page Last Page  
New Topic Reply
 Rating:  Rating
 Posted: Wed Jun 23rd, 2021 03:24 pm
PM Quote Reply
2426th Post
Ranger_Danger_
Ranger Gal


Joined: Tue Nov 14th, 2017
Location: Florida USA
Posts: 229
Name: Kaylee Dale
Occupation: Parts Counterperson
Interests: Dirt Bikes, Trucks, Off-Roading
Status: 
Offline
Reputation: 
Reputation Points: 979
Hello my lovely Ranger people. 
Long time no talk. :) 
Haven't done anything except get an alignment and have the shop put adjustable Camber Bolts in the truck. 

Otherwise, I am waiting for winter time to paint the frame on the ranger. FL is too humid during summer for the paint to cure and I am not fortunate enough to have a shop to spray it in.



____________________
"So Many Ideas. So Little Money."
"If You Ain't First, You're Last."
--
2007 Honda Accord 2.4L(New Daily)
2005 Ranger 2.3L 2WD XLT (My Baby)
2000 Explorer 5.0L 2WD Eddie Bauer (Donor)
2008 Yamaha YZ85(Toy)
2008 Honda CRF230L(My 2nd Toy)
2021 Ford F-150 Eco 2.7L (Boyfriend's DD)
1984 Mustang (Boyfriend's Project)
2009 Kawasaki KLR650(Boyfriend's 2nd Toy)
Back To Top PM Quote Reply

 Posted: Sat Jul 3rd, 2021 01:07 am
PM Quote Reply
2427th Post
Tsquare
Member


Joined: Fri Nov 10th, 2017
Location: Suwanee GeorgiaUSA
Posts: 1469
Name: 
Occupation: Controlled Insanity
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 2739
I got the rubber mat back in the bed and the work box back in. 

I have lockable storage once again.



____________________
Tony
NE ATL
'04 XLT regular cab 3.slo stepside
Came out of retirement to drive a school bus - I have lost my mind
Back To Top PM Quote Reply

 Posted: Mon Jul 5th, 2021 12:28 am
PM Quote Reply
2428th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
Happy 4th of July, folks!

Well, I installed a newly rebuilt Traction-Lock diff carrier and a rear sway bar today.  Finished stripping AW's wrecked Ranger and ended up with these pieces so I put them to use.  We also have a nice Reese hitch that I believe I will put on my truck as well.  Since he isn't looking to buy another Ranger, I suddenly have all these goodies for my truck.  I guess his "Gold Dust" will live on, in part, with my truck.



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Mon Jul 5th, 2021 02:11 am
PM Quote Reply
2429th Post
Tsquare
Member


Joined: Fri Nov 10th, 2017
Location: Suwanee GeorgiaUSA
Posts: 1469
Name: 
Occupation: Controlled Insanity
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 2739
Michael, wasn't Gold Dust a 4x4? And did it have a LS rear?


Just a thought.



____________________
Tony
NE ATL
'04 XLT regular cab 3.slo stepside
Came out of retirement to drive a school bus - I have lost my mind
Back To Top PM Quote Reply

 Posted: Mon Jul 5th, 2021 06:25 pm
PM Quote Reply
2430th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
@Tony: Yes, Gold Dust was a 1999 XLT 4X4.  Originally, it came with a 7.5" open diff.  He upgraded it to an 8.8" Trac-Lock diff.  He installed new clutch packs in it before he slipped it under the truck.  Has less than 2500 miles on it after the rebuild.  That is the diff carrier I put in mine yesterday.

As for the 4X4 stuff, I have no aspirations to make my EDGE a 4X4 truck... way too much work for me.  The front suspension took a super hard hit, so all of the new stuff he had put under the front are toast.  He had installed new upper and lower control arms, so all new bushings and ball joints as well as new tie rod ends.  Everything is bent or screwed up in some way or another, so I wouldn't trust those parts on my truck.

Last edited on Mon Jul 5th, 2021 06:28 pm by mhoward



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Mon Jul 5th, 2021 06:28 pm
PM Quote Reply
2431st Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
Well, that was weird.  I just found out you can't use the "less than" symbol in your post.  Anything after it, including the symbol is omitted from your post.  Chris???



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Mon Jul 5th, 2021 09:59 pm
PM Quote Reply
2432nd Post
Tsquare
Member


Joined: Fri Nov 10th, 2017
Location: Suwanee GeorgiaUSA
Posts: 1469
Name: 
Occupation: Controlled Insanity
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 2739
It was just a thought. For me I will not have a truck without a limited slip rear. I have had a few 4x4's but had no real use of them outside of recreation. The 4x4's were slower, got worse fuel mileage, and had too many expensive moving parts that wore out prematurely. They also give you a false sense of security when you come across the hunting trail that is underwater. With only rear wheel drive I would look at that same trail and not even think about going down it. 

To throw in the multiplier effect mount a 10K winch on the front end. That gives you the added capability to pull up every tree that you can hook up to when you sink a 4x4.  With a LS 2wd there are far fewer "hold my beer and watch this" stories that can be told later.

For example: Back in 1990 I had a 78 F-100 XLT 4x4 with the factory 3" lift running 38 Ground Hawgs. It had a 400 SB, granny gear 4 speed, and 373 locker rear with a spool up front. I got that truck stuck 2 times. The first time it took 3 logging Timber Jacks to get to it and drag it out of the swamp. The Timber Jacks and I got stuck multiple times getting out of that mud hole back to solid ground.  That is when I got the winch. When I got it stuck that time I pulled 4 pine trees up that were all 10 to 12 inches in diameter. I got unstuck by a D-6 bulldozer as the jeeps and other trucks that would try to get back to where I was couldn't make it.



____________________
Tony
NE ATL
'04 XLT regular cab 3.slo stepside
Came out of retirement to drive a school bus - I have lost my mind
Back To Top PM Quote Reply

 Posted: Sun Jul 11th, 2021 03:44 pm
PM Quote Reply
2433rd Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
Not sure if anyone else is experiencing this, but for whatever reason, I am no longer getting notifications for subscribed threads.  The little box beside "To receive email notifications when new posts are made to this topic, tick this box :" is checked.  This thread is where I have noticed the issue, but I am subscribed to MANY threads and I am getting ZERO notifications.

Chris/Jim:  any ideas why I don't get my notifications anymore?

I have checked my junk mail setting and I actually have "administration@ford-rangers.com" in my Safe Senders list.



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Wed Jul 21st, 2021 02:10 am
PM Quote Reply
2434th Post
Tsquare
Member


Joined: Fri Nov 10th, 2017
Location: Suwanee GeorgiaUSA
Posts: 1469
Name: 
Occupation: Controlled Insanity
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 2739
I did a little work with the truck today. I have these 4 large shrubs on one side of my house where all of the utilities and HVAC reside. My wife has hated them for years and wanted them removed. I was able to cut down 3 and a third  in between the rains today and load it into the bed of the Ranger. I cut it to length of the bed and stacked it about six inches higher than the cab then tied it down. I made the trip to the inert waste dump where they easily slid out the back of the truck. 

While I was there a Dodge Ram got stuck in the mud. After I unloaded I pulled around him and I pulled his open dif truck out of the muck. It didn't take much but I had just enough umph to get him past the slippery spot. It took a lot of effort not to tell him he needs to buy a real truck. Got to love limited slip rears.



____________________
Tony
NE ATL
'04 XLT regular cab 3.slo stepside
Came out of retirement to drive a school bus - I have lost my mind
Back To Top PM Quote Reply

 Posted: Wed Jul 21st, 2021 12:45 pm
PM Quote Reply
2435th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
@Tony: LMAO, that HAD to feel good! :-)



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Wed Jul 21st, 2021 05:20 pm
PM Quote Reply
2436th Post
Tsquare
Member


Joined: Fri Nov 10th, 2017
Location: Suwanee GeorgiaUSA
Posts: 1469
Name: 
Occupation: Controlled Insanity
Interests: 
Status: 
Offline
Reputation: 
Reputation Points: 2739
I wish I could have gotten a picture of it. It made my week.



____________________
Tony
NE ATL
'04 XLT regular cab 3.slo stepside
Came out of retirement to drive a school bus - I have lost my mind
Back To Top PM Quote Reply

 Posted: Sun Aug 29th, 2021 05:42 am
PM Quote Reply
2437th Post
97rangerstepside
Member


Joined: Mon Oct 23rd, 2017
Location: Washington USA
Posts: 147
Name: Jeff
Occupation: 
Interests: Guns, outdoors, camping, riding motorcycles.
Status: 
Offline
Reputation: 
Reputation Points: 327
Did a front end alignment and front brake job to get it ready for daily commuting for a new job after 3 years of taking a company rig home.



____________________
1997 Ford Ranger XLT 2.3 5speed
Mods, Explorer limited leather buckets, shorty console, sport trac white face gauges, proper hitch, proper spray in bedliner, UWS toolbox. 20% tinted windows
2004 Jeep Wrangler 2.4 5speed (toy)
3” coil spacer lift, 31x10.5x15 all terrains.
2002 Ford Ranger Xlt 4dr extended cab 4.0 auto 2wd
Back To Top PM Quote Reply

 Posted: Sun Aug 29th, 2021 03:20 pm
PM Quote Reply
2438th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
@97RangerStepside: Same company, different position, or new company?



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Sun Aug 29th, 2021 05:14 pm
PM Quote Reply
2439th Post
97rangerstepside
Member


Joined: Mon Oct 23rd, 2017
Location: Washington USA
Posts: 147
Name: Jeff
Occupation: 
Interests: Guns, outdoors, camping, riding motorcycles.
Status: 
Offline
Reputation: 
Reputation Points: 327
New job with a new company, getting a huge pay raise with better work hours.



____________________
1997 Ford Ranger XLT 2.3 5speed
Mods, Explorer limited leather buckets, shorty console, sport trac white face gauges, proper hitch, proper spray in bedliner, UWS toolbox. 20% tinted windows
2004 Jeep Wrangler 2.4 5speed (toy)
3” coil spacer lift, 31x10.5x15 all terrains.
2002 Ford Ranger Xlt 4dr extended cab 4.0 auto 2wd
Back To Top PM Quote Reply

 Posted: Sun Aug 29th, 2021 08:09 pm
PM Quote Reply
2440th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
Well!  Congratulations on the new employment and better pay/hours! :-)



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Sun Aug 29th, 2021 08:12 pm
PM Quote Reply
2441st Post
JAMMAN

Owns A Torsen


Joined: Mon Sep 18th, 2017
Location: Grove City OhioUSA
Posts: 5794
Name: Jim
Occupation: 5 axis cnc programmer
Interests: RBV's
Status: 
Offline
Reputation: 
Reputation Points: 9388
That's always good news :)



____________________
Truth sounds like hate for those who hate truth.
Let's Go Brandon!
00 XLT 4WD RCSB 3.GO! Jalapeño
01 XLT 2WD RC Steppie 3.0 auto Silver
Back To Top PM Quote Reply

 Posted: Fri Sep 3rd, 2021 03:13 pm
PM Quote Reply
2442nd Post
Chris

Wrench spinner


Joined: Thu Oct 5th, 2017
Posts: 1970
Name: Chris
Occupation: Retired
Interests: Science, technology, horses
Status: 
Online
Reputation: 
Reputation Points: 2671
mhoward wrote:
Well, that was weird.  I just found out you can't use the "less than" symbol in your post.  Anything after it, including the symbol is omitted from your post.  Chris???
Sorry - didn't spot this in this thread!

The less than < symbol seems to work fine for me ...



____________________


MG power
Back To Top PM Quote Reply

 Posted: Fri Sep 3rd, 2021 03:22 pm
PM Quote Reply
2443rd Post
Chris

Wrench spinner


Joined: Thu Oct 5th, 2017
Posts: 1970
Name: Chris
Occupation: Retired
Interests: Science, technology, horses
Status: 
Online
Reputation: 
Reputation Points: 2671
mhoward wrote:
Not sure if anyone else is experiencing this, but for whatever reason, I am no longer getting notifications for subscribed threads.  The little box beside "To receive email notifications when new posts are made to this topic, tick this box :" is checked.  This thread is where I have noticed the issue, but I am subscribed to MANY threads and I am getting ZERO notifications.

Chris/Jim:  any ideas why I don't get my notifications anymore?

I have checked my junk mail setting and I actually have "administration@ford-rangers.com" in my Safe Senders list.

Your watched fora were all turned off - that may have affected it - I have turned them on, let me know if you now get notifications.



____________________


MG power
Back To Top PM Quote Reply

 Posted: Sat Sep 4th, 2021 01:13 am
PM Quote Reply
2444th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
Chris wrote:
mhoward wrote:

Well, that was weird.  I just found out you can't use the "less than" symbol in your post.  Anything after it, including the symbol is omitted from your post.  Chris???
Sorry - didn't spot this in this thread!

The less than < symbol seems to work fine for me ...

Hmmm, that must mean I get < you, Chris!

Edit: aaaannnnddd, of course, it works now.  Go figure!

Last edited on Sat Sep 4th, 2021 01:14 am by mhoward



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Sat Sep 4th, 2021 01:16 am
PM Quote Reply
2445th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
Chris wrote:
mhoward wrote:

Not sure if anyone else is experiencing this, but for whatever reason, I am no longer getting notifications for subscribed threads.  The little box beside "To receive email notifications when new posts are made to this topic, tick this box :" is checked.  This thread is where I have noticed the issue, but I am subscribed to MANY threads and I am getting ZERO notifications.

Chris/Jim:  any ideas why I don't get my notifications anymore?

I have checked my junk mail setting and I actually have "administration@ford-rangers.com" in my Safe Senders list.

Your watched fora were all turned off - that may have affected it - I have turned them on, let me know if you now get notifications.

Yep!  Now I have 5 in my inbox as we speak!  Wonder how that got turned off?  Thanks for the fix, Chris!



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Sat Sep 4th, 2021 02:49 pm
PM Quote Reply
2446th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
mhoward wrote:
Chris wrote:

mhoward wrote:


Not sure if anyone else is experiencing this, but for whatever reason, I am no longer getting notifications for subscribed threads.  The little box beside "To receive email notifications when new posts are made to this topic, tick this box :" is checked.  This thread is where I have noticed the issue, but I am subscribed to MANY threads and I am getting ZERO notifications.

Chris/Jim:  any ideas why I don't get my notifications anymore?

I have checked my junk mail setting and I actually have "administration@ford-rangers.com" in my Safe Senders list.

Your watched fora were all turned off - that may have affected it - I have turned them on, let me know if you now get notifications.

Yep!  Now I have 5 in my inbox as we speak!  Wonder how that got turned off?  Thanks for the fix, Chris!

Okay, I just noticed that I am getting TWO notifications for each post of a subscribed thread.

* One comes in that has the link "Click here to go to the new post" like I always would get in the past
* One comes in that has the link "General Ranger Discussion > What did you do to your Ranger today?"
   below that, "From: Chris"
   below that, the date of the post  
   below that, a green Reply Button
These are examples take from the notification about this thread.  I didn't realize at first what was happening, then it was like; "I just posted a reply to that".  I'm going to have a look at my settings, but if you know what is causing the double notification and fix it, that would be great![url=https://ford-rangers.com/view_topic.php?id=2191&forum_id=40&jump_to=33652#p33652][/url]



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Sat Sep 4th, 2021 05:22 pm
PM Quote Reply
2447th Post
Chris

Wrench spinner


Joined: Thu Oct 5th, 2017
Posts: 1970
Name: Chris
Occupation: Retired
Interests: Science, technology, horses
Status: 
Online
Reputation: 
Reputation Points: 2671
One is the forum notification the other is the thread notification - I have tweaked the settings - let me know whether you just get the thread notification now.



____________________


MG power
Back To Top PM Quote Reply

 Posted: Sat Sep 4th, 2021 09:11 pm
PM Quote Reply
2448th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
Chris wrote:
One is the forum notification the other is the thread notification - I have tweaked the settings - let me know whether you just get the thread notification now.
I got two notifications for this quoted post of yours @11:23am (my local time).  I looked at my profile and it showed my forum notifications were all checked (that would be my preference).  The thread notifications were all unchecked and I left it that way.  I dunno, it's not really a major issue, just confusing as to why it's happening.



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

 Posted: Sat Sep 4th, 2021 09:29 pm
PM Quote Reply
2449th Post
Mike69

Mustang Nut


Joined: Sun Oct 22nd, 2017
Location: Horsepasture VirginiaUSA
Posts: 1546
Name: Mike
Occupation: Merchandising
Interests: Vintage Mustangs, RBV's, car shows, & woodworking
Status: 
Offline
Reputation: 
Reputation Points: 2771
I have had a squeaking noise from the f/e of my Ranger for a little while now. Since we moved it has not been driven for a couple weeks until the end of last week, & it turns out it is coming from the serpentine belt or the tensioner/idler pulleys. I ordered a new belt & went to change it today & found the tensioner bolt was loose enough to remove without a wrench & one rib of the serpentine belt was gone all the way around the belt. I removed the tensioner & checked it to make sure it was not damaged & the pulley was not making noise. I also checked the idler pulley to make sure it was not making any noise either, they were both OK. I reinstalled the tensioner & tightened it & installed the new serpentine belt & what do you know the noise is gone. Good thing I fixed it now since I go back to work on Monday & do not want any problems even though I am only 15 minutes from home.



____________________
21 Bronco Sport Big Bend,
00 Ranger Extd Cab 4x4 4.0 OHV, Auto(My DD)
99 Explorer Sport 4x4 4.0 SOHC, Auto( Wife's DD)
69 Mustang Coupe 5.0, 5 spd(Project & my future toy)
14 Kawasaki Vulcan (Wife's Toy)
Back To Top PM Quote Reply

 Posted: Sat Sep 4th, 2021 10:00 pm
PM Quote Reply
2450th Post
mhoward
Hey look ↓ they ↓ bounce!


Joined: Sun Oct 22nd, 2017
Location: Evansville IndianaUSA
Posts: 2526
Name: Michael
Occupation: Technology Manager
Interests: Trucks / Guitars & Music / Things that go BANG
Status: 
Offline
Reputation: 
Reputation Points: 3951
@Chris: I received only one notification for Mike's post above.  Mike posted in his "moving to NJ" thread and I only received one notification for that one as well.  You may have the problem resolved.  *fingers crossed*



____________________
-- Michael

2003 Ranger Edge / Extended Cab / Flareside / 3.0L FLEX / Auto / 2WD / 8.8 LS 4:10 / Sonic Blue Pearl

So many mods... so little time...



Back To Top PM Quote Reply

Current time is 11:10 am Top Page:  First Page Previous Page  ...  94  95  96  97  98  99  100  Next Page Last Page    

Ford-Rangers.com Ranger Forum > Welcome To The Newest Ford Ranger Forum > General Ranger Discussion > What did you do to your Ranger today?

Users viewing this topic



© 2007-2021 Chris -N- Jim
Page processed in 0.4363 seconds (36% database + 64% PHP). 110 queries executed.